Vimba 1.3 - The SDK for Allied Vision cameras

Vimba is our future-proof platform-independent SDK for all Allied Vision cameras with GigE Vision and FireWire (IEEE 1394) interface.


  • NEW: ARM support
  • Vimba is operating system independent
  • Platform-independent APIs for C, C++, and .NET
  • Vimba is based on the GenICam standard.
  • GenICam-based third-party software automatically connects with Vimba's TLs (transport layers).
  • Cognex Adapter for VisionPro (version 6.0 or later)
  • Integrated viewer
  • License for every Allied Vision camera free of charge
  • Many examples

Compatible operating systems and cameras

Operating systems:

  • Windows
    Windows XP (32-bit only)*, Windows 7 (32-bit and 64-bit), Windows 8 (32-bit and 64-bit)*
  • Linux
    Linux on standard PCs based on Intel-compatible 32-bit and 64-bit as well as ARMv7 processors. Currently, only the GigE Vision transport layer is available. Tested distributions:

    • Fedora 17
    • Debian 6.0.7
    • Ubuntu 12.4

  • Support for QNX and OS X is planned. The PvAPI (only for GigE cameras) has been ported to QNX and OS X and can be used to integrate our GigE Vision cameras.

Supported cameras:

  • Allied Vision 1394 cameras (Windows only)
  • Allied Vision GigE Vision cameras
  • Vimba will support future USB3 Vision cameras


* Windows XP and Windows 8: Before installing Vimba, .NET Framework 2.0 SP2 or .NET Framework 3.x must be installed: . Later versions contained in Windows 8 are incompatible.



Third-party software solutions


You can also use Allied Vision cameras with numerous third-party software solutions.