Use Vimba instead of Universal Package for MATLAB

Vimba is our future-proof SDK for all current Allied Vision cameras with GigE Vision and FireWire (IEEE 1394) interface, whereas the Universal Package is a legacy SDK that is no longer recommended for use with MATLAB.

  1. Uninstall the Universal Package (or at least unregister the AVT Adaptor for MATLAB).
  2. Download Vimba from:
  3. Install Vimba (do not deselect the transport layers).
  4. Use Vimba's GenTL-compliant transport layer with MATLAB 2012b (or higher), which provides the 'gentl' Adaptor to access the GenTL transport layers. Do not use the GenICam_VC80_i86_v_2_3_0 driver from MathWorks.

Starting with version R2014a, MATLAB requires to install the GenTL Support Package.
Download Support Package for GenICam GenTL Interface.

The MATLAB Adaptor uses the UniAPI proprietary feature names, whereas Vimba's GenTL uses the GenICam standard feature names for GigE and FireWire cameras. Please consider these differences.


Zurück zur Übersicht