Mixed mode exception with Visual Studio .NET 4.0 or higher

Vimba's .Net assemblies are built for the .NET 2.0 framework (the current version is 4.5). In order to achieve backward compatibility, go to the application directory and modify the framework version to be used in the configuration file *config:

<configuration>
  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.5" />
  </startup>
</configuration>


More information:
msdn.microsoft.com/en-us/library/ee518876.aspx

If the *.config data in the application directory are missing, try the following workaround:
Convert the project into a previous .NET version (for example, .NET 4 into .NET 3.5) and build the project.
Convert it back into the higher .NET version. This normally creates the *config file.
 



Zurück zur Übersicht