Vimba 1.3 - Das SDK für Allied Vision Kameras

Vimba ist unser zukunftssicheres, plattformunabhängiges SDK für alle Allied Vision Kameras mit GigE Vision und FireWire (IEEE 1394) Interface.

Highlights

  • NEU: ARM-Unterstützung
  • Vimba ist betriebssystemunabhängig
  • Plattformunabhängige APIs für C, C++ und .NET
  • Vimba basiert auf dem GenICam Standard.
  • GenICam-basierte Software von Drittanbietern verbindet sich automatisch mit Vimbas TLs (Transport Layer).
  • Cognex Adapter für VisionPro (ab Version 6.0).
  • Integrierter Viewer
  • Kostenlose Lizenz für jede Allied Vision Kamera
  • Viele Beispiele

Betriebssysteme und kompatible Kameras

Betriebssysteme:

  • Windows
    Windows XP (nur 32-Bit)*, Windows 7(32-Bit und 64-Bit), Windows 8 (32-Bit und 64-Bit)*
  • Linux
    Linux auf Standard-PCs mit Intel-kompatiblen 32-Bit und 64-Bit sowie ARMv7 Prozessoren. Zurzeit ist für Linux nur der GigE Vision Transport Layer verfügbar. Getestete Distributionen:

    • Fedora 17 "Beefy Miracle"
    • Debian 6.0.7 "Squeeze"
    • Ubuntu 12.04 LTS "Precise Pangolin"

  • Unterstützung von QNX und OS X ist geplant. Die PvAPI (nur für GigE Kameras) wurde bereits zu QNX und OS X portiert und kann genutzt werden, um unsere GigE Kameras zu integrieren.

Unterstützte Kameras:

  • Allied Vision 1394 Kameras (nur Windows)
  • Allied Vision GigE Vision Kameras
  • Vimba wird zukünftige USB 3 Vision Kameras unterstützen


*
Windows XP und Windows 8: Bevor Vimba installiert wird, muss .NET Framework 2.0 SP2 oder .NET Framework 3.x installiert sein: msdn.microsoft.com/netframework/cc378097

Downloads

 

Third-Party Softwarelösungen

 

Sie können Allied Vision Kameras auch mit zahlreichen Third-Party Softwarelösungen betreiben.